Where we share news, updates and tutorials with our lovely customers.

UpThemes Framework 2.3 Now Uses Iris Colorpicker & New Media Uploader

I’m extremely excited to announce that the UpThemes Framework, our tiny little theme options framework, now uses the new WordPress 3.5 Iris colorpicker as well as the new media uploader.

What Does This Mean for Users?

Well, for one, it means you must upgrade to WordPress 3.5 before using the latest version of our themes. The framework is no longer backwards-compatible with old versions of WordPress. Sorry, but we want you to be as secure and up-to-date as possible.

For two, it means easy usage of the Live Theme Customizer to preview your theme modifications without tinkering with your live site until the changes are loaded in and ready for launch.

What Does It Mean for Developers?

Same stuff as above. No changes are required to the way you instantiate your theme options. Simply create your option arrays just like before and the new colorpicker and image uploader will work seamlessly out of the box.

Thank You!

I want to recognize two developers that helped (unknowingly) contribute to this update. Rachel Baker, wrote a lovely post on how to use the new WordPress color picker in a plugin, which helped me out tremendously when implementing this new functionality for the UpThemes Framework. Also, Thomas Griffin, developer of the incredible Soliloquy plugin, who wrote a well-documented and extremely simple plugin to help folks like me integrate the new WP media utility. Thanks Rachel and Thomas!

Questions? Let Us Know!

If you come across any issues, feel free to help us out on Github, where the UpThemes Framework is currently hosted and being actively developed.

Leave a Reply

Win an iPad AirĀ® or lifetime license of the Worldview Theme!Enter Now
%d bloggers like this: